BETA

13th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/07/18 01:21 PM] with 'Partial Outage'

Issue has been resolved at [13/07/18 01:22 PM]