BETA

12th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/07/18 12:58 PM] with 'Major Outage'

Issue has been resolved at [12/07/18 01:01 PM]