BETA

12th July 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/07/18 04:00 AM] with 'Major Outage'

Issue has been resolved at [12/07/18 04:03 AM]