BETA

14th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [14/03/19 11:59 AM] with 'Partial Outage'

Issue has been resolved at [14/03/19 12:05 PM]