BETA

11th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [11/07/18 01:31 PM] with 'Partial Outage'

Issue has been resolved at [11/07/18 01:32 PM]