BETA

11th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/07/18 07:36 AM] with 'Partial Outage'

Issue has been resolved at [11/07/18 07:37 AM]