BETA

11th July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/07/18 03:55 AM] with 'Major Outage'

Issue has been resolved at [11/07/18 03:57 AM]