BETA

10th July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [10/07/18 12:13 PM] with 'Partial Outage'

Issue has been resolved at [10/07/18 12:16 PM]