BETA

10th July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [10/07/18 11:37 AM] with 'Major Outage'

Issue has been resolved at [10/07/18 11:39 AM]