BETA

10th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [10/07/18 08:05 AM] with 'Partial Outage'

Issue has been resolved at [10/07/18 08:06 AM]