BETA

10th July 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [10/07/18 03:08 AM] with 'Major Outage'

Issue has been resolved at [10/07/18 03:11 AM]