BETA

9th July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [09/07/18 06:04 AM] with 'Partial Outage'

Issue has been resolved at [09/07/18 06:05 AM]