BETA

8th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/07/18 08:33 PM] with 'Partial Outage'

Issue has been resolved at [08/07/18 08:35 PM]