BETA

5th April 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [05/04/17 06:40 PM] with 'Major Outage'

Issue has been resolved at [05/04/17 06:42 PM]