BETA

7th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [07/07/18 02:56 PM] with 'Partial Outage'

Issue has been resolved at [07/07/18 02:58 PM]