BETA

5th July 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [05/07/18 01:44 PM] with 'Major Outage'

Issue has been resolved at [05/07/18 02:32 PM]