BETA

5th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [05/07/18 10:15 AM] with 'Major Outage'

Issue has been resolved at [05/07/18 10:16 AM]