BETA

5th July 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/07/18 10:11 AM] with 'Partial Outage'

Issue has been resolved at [05/07/18 10:12 AM]