BETA

3rd July 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [03/07/18 12:21 PM] with 'Partial Outage'

Issue has been resolved at [03/07/18 02:34 PM]