BETA

5th April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/04/17 06:33 PM] with 'Partial Outage'

Issue has been resolved at [05/04/17 06:35 PM]