BETA

30th April 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/04/19 05:26 AM] with 'Partial Outage'

Issue has been resolved at [30/04/19 05:31 AM]