BETA

30th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [30/06/18 11:34 AM] with 'Partial Outage'

Issue has been resolved at [30/06/18 11:42 AM]