BETA

30th June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/06/18 02:38 AM] with 'Partial Outage'

Issue has been resolved at [30/06/18 02:40 AM]