BETA

5th April 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/04/17 06:12 PM] with 'Major Outage'

Issue has been resolved at [05/04/17 06:15 PM]