BETA

29th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/06/18 09:00 PM] with 'Major Outage'

Issue has been resolved at [29/06/18 09:01 PM]