BETA

30th April 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [30/04/19 04:43 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/04/19 04:46 AM]