BETA

29th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/06/18 06:55 PM] with 'Partial Outage'

Issue has been resolved at [29/06/18 07:01 PM]