BETA

29th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/06/18 05:10 PM] with 'Partial Outage'

Issue has been resolved at [29/06/18 05:18 PM]