BETA

29th June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [29/06/18 04:00 PM] with 'Major Outage'

Issue has been resolved at [29/06/18 04:01 PM]