BETA

29th June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/06/18 03:23 PM] with 'Partial Outage'

Issue has been resolved at [29/06/18 03:24 PM]