BETA

29th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [29/06/18 10:55 AM] with 'Partial Outage'

Issue has been resolved at [29/06/18 10:57 AM]