BETA

28th June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [28/06/18 07:49 PM] with 'Partial Outage'

Issue has been resolved at [28/06/18 07:51 PM]