BETA

5th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/04/17 06:04 PM] with 'Major Outage'

Issue has been resolved at [05/04/17 06:05 PM]