BETA

28th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [28/06/18 01:41 PM] with 'Major Outage'

Issue has been resolved at [28/06/18 01:44 PM]