BETA

27th June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/06/18 05:13 AM] with 'Partial Outage'

Issue has been resolved at [27/06/18 05:44 AM]