BETA

26th June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [26/06/18 06:44 PM] with 'Major Outage'

Issue has been resolved at [26/06/18 06:46 PM]