BETA

26th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [26/06/18 01:24 PM] with 'Major Outage'

Issue has been resolved at [26/06/18 01:26 PM]