BETA

26th June 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [26/06/18 09:15 AM] with 'Major Outage'

Issue has been resolved at [26/06/18 09:16 AM]