BETA

26th June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [26/06/18 03:57 AM] with 'Major Outage'

Issue has been resolved at [26/06/18 03:59 AM]