BETA

25th June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [25/06/18 03:20 PM] with 'Major Outage'

Issue has been resolved at [25/06/18 03:23 PM]