BETA

24th June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/06/18 09:00 PM] with 'Major Outage'

Issue has been resolved at [24/06/18 09:01 PM]