BETA

23rd June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [23/06/18 02:44 PM] with 'Partial Outage'

Issue has been resolved at [23/06/18 02:46 PM]