BETA

25th June 2016

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [25/06/16 03:16 PM] with 'Partial Outage'

Issue has been resolved at [25/06/16 03:22 PM]