BETA

22nd June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/06/18 08:21 PM] with 'Major Outage'

Issue has been resolved at [22/06/18 08:22 PM]