BETA

21st June 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [21/06/18 02:39 PM] with 'Major Outage'

Issue has been resolved at [21/06/18 02:41 PM]