BETA

20th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [20/06/18 02:46 AM] with 'Partial Outage'

Issue has been resolved at [20/06/18 02:50 AM]