BETA

18th June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/06/18 06:35 PM] with 'Partial Outage'

Issue has been resolved at [18/06/18 06:37 PM]