BETA

18th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/06/18 11:36 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [19/06/18 10:48 AM]