BETA

14th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/03/19 11:35 AM] with 'Partial Outage'

Issue has been resolved at [14/03/19 11:36 AM]