BETA

18th June 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/06/18 10:19 AM] with 'Partial Outage'

Issue has been resolved at [18/06/18 10:21 AM]